The OnePlus 6 is officially on sale! Buy now →
Remove All Ads from XDA

Can't uninstall Xposed on oreo

3 posts
Thanks Meter: 0
 
By benvrakas, Junior Member on 13th May 2018, 06:00 AM
Post Reply Email Thread
So here's what happened:
I installed a new rom: Google wiz 44. A touchwiz based Android 8.0 rom. It has magisk pre-installed. In magisk, I get the systemless xposed SDK26 module. It installs fine but after reboot there is no Xposed installer APK. To fix this I also install the normal Xposed module from magisk repo. This gets me the Xposed installer APK and after a reboot it detects Xposed is installed. The problem now is I cannot uninstall Xposed framework even with the uninstaller zip. I have tried removing the sdk26 Xposed from magisk but it doesn't uninstall Xposed. Can't pass saftynet.
 
 
13th May 2018, 08:43 AM |#2  
Didgeridoohan's Avatar
Recognized Contributor
Flag Gothenburg
Thanks Meter: 4,332
 
Donate to Me
More
If you'd have read the documentation for the Xposed module, or the OP of the Systemless Xposed support thread, you'd have seen that you need to install the modified installer for that module manually.

Now, the question is what you mean by the "normal Xposed module from magisk repo". Do you mean the Unity version? Because that's also a systemless Xposed version, just by a different creator...

So now you have two systemless Xposed modules installed? That sounds like it could cause problems...

You can't use the Xposed uninstaller zip for a Magisk systemless Xposed module. It won't recognise it. Since it sounds like you've installed everything through Magisk, you can uninstall through Magisk. When you say you've tried and it doesn't work, what do you mean? Have you gone to the modules section of the Magisk Manager and pressed the trash bin icon next to the module you want to remove and then rebooted? More details, please...

And lastly, you can never pass SafetyNet with Xposed installed and active.
17th May 2018, 10:27 AM |#3  
marcdw's Avatar
Senior Member
Flag Baldwin Park
Thanks Meter: 2,147
 
More
@benvrakas, maybe try the UNITY installer. It acts as an installer, uninstaller, and upgrader.
Flash it and pay attention to the output. It'll tell you what it's doing.
If it installs on first flash, flash it again for an uninstall. Hopefully it'll remove things successfully. Just another option.

http://forum.xda-developers.com/show....php?t=3697756

Xposed Framework [UNITY]


Maybe this more involved method may work.
http://forum.xda-developers.com/show...php?p=76064855



Moto G5S Plus XT1806, FireHound v4.5 ROM, MultiROM, Tapatalk 4.9.5
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes