Remove All Ads from XDA

[2018.5.6][Magisk] Systemless Xposed v89.3/v90.2-beta3 (SDK 21-27)

1,800 posts
Thanks Meter: 46,647
 
By topjohnwu, Recognized Developer / Recognized Contributor on 29th May 2016, 08:22 AM
Post Reply Email Thread
17th April 2018, 08:38 AM |#6941  
Senior Member
Thanks Meter: 29
 
More
Wifi Is completely disabled when I install this module with no way of turning it back on unless I disable the module.

Any idea if there is a fix for wifi?
 
 
17th April 2018, 11:47 AM |#6942  
Junior Member
Thanks Meter: 2
 
More
My Xposed Installer app displays a warning:
"Xposed is not (yet) compatible with Android SDK version 26 on your processor architecture (arm64-v8a)."

I have the Xperia XZ1 Compact, 8.0 Oreo (47.1.A.12.75) and installed the 3.1.5 installer (installing the sdk26 one did nothing).

Otherwise it seems to work fine, but re-activating Xposed is a really long process:
1. Re-check the Xposed module, reboot.
2. Inside Xposed Installer, the slider is "on" but it's still not active. Another reboot.
3. Inside Xposed Installer, dismiss the warning about bootloops (even though you chose never to see it again) and re-check all your modules again. A third reboot.
Would it be possible to make it easier to re-activate Xposed by just requiring one reboot with all my modules active?
17th April 2018, 04:09 PM |#6943  
Rom's Avatar
Senior Member
Flag Lyon
Thanks Meter: 822
 
Donate to Me
More
Quote:
Originally Posted by ajp_anton

My Xposed Installer app displays a warning:
"Xposed is not (yet) compatible with Android SDK version 26 on your processor architecture (arm64-v8a)."

I have the Xperia XZ1 Compact, 8.0 Oreo (47.1.A.12.75) and installed the 3.1.5 installer (installing the sdk26 one did nothing).

Otherwise it seems to work fine, but re-activating Xposed is a really long process:
1. Re-check the Xposed module, reboot.
2. Inside Xposed Installer, the slider is "on" but it's still not active. Another reboot.
3. Inside Xposed Installer, dismiss the warning about bootloops (even though you chose never to see it again) and re-check all your modules again. A third reboot.
Would it be possible to make it easier to re-activate Xposed by just requiring one reboot with all my modules active?

As you probably know, the development of Xposed for Android Oreo is still at a non-stable stage (BETA), hence the fact that you are having difficulty making it work properly.

I suggest you start a new topic directly on the github page:
https://github.com/rovo89/Xposed/issues

(NB: Don't forget to include as many log files as you can, this could greatly help rovo.)
17th April 2018, 10:23 PM |#6944  
Status for my Note 8 (SM-N950F): xposed is working on TouchWiz. Currently successfully using following modules:
• App Locale 2
• Firefds Kit (Oreo)
• GravityBox [O] (Not usable at the moment. Crashes unlocking methods and you have to disable the xposed module to fix it! See https://forum.xda-developers.com/app...-mode-t3693165 if you're in trouble.)

Just a warning: Be careful if you're using GravityBox. It's clearly stated, it isn't for heavily modified versions of Android and xposed is still beta. Some options work, some won't. Don't use options you need a restart for.

Thanks for the work @topjohnwu and @rovo89 and all module devs for xposed and Magisk!
18th April 2018, 08:21 AM |#6945  
Member
Flag Hannover
Thanks Meter: 3
 
More
I am using latest Magisk (with fix for Galaxy S9) and (systemless) Xposed module.
Everything was running fine until I disabled the Xposed module in Magisk manager and did a reboot.

Now, my phone is stuck in a bootloop. The boot process gets to "optimizing apps", counts to 98/98 and reboots again.

Is there anything I can do except for restoring from a backup in twrp?
Is it possible to re-enable xposed in twrp via editing a config file?
18th April 2018, 09:47 AM |#6946  
super-drone's Avatar
Senior Member
Thanks Meter: 78
 
More
Quote:
Originally Posted by massaquah

I am using latest Magisk (with fix for Galaxy S9) and (systemless) Xposed module.
Everything was running fine until I disabled the Xposed module in Magisk manager and did a reboot.

Now, my phone is stuck in a bootloop. The boot process gets to "optimizing apps", counts to 98/98 and reboots again.

Is there anything I can do except for restoring from a backup in twrp?
Is it possible to re-enable xposed in twrp via editing a config file?

flash magisk uninstaller in twrp
The Following User Says Thank You to super-drone For This Useful Post: [ View ] Gift super-drone Ad-Free
18th April 2018, 10:26 AM |#6947  
Member
Flag Hannover
Thanks Meter: 3
 
More
Quote:
Originally Posted by super-drone

flash magisk uninstaller in twrp

Thank you.

And just using Magisk Mount and editing some file to re-enable Xposed module won't work?
18th April 2018, 11:40 AM |#6948  
jenslody's Avatar
Senior Member
Thanks Meter: 914
 
Donate to Me
More
Quote:
Originally Posted by massaquah

Thank you.

And just using Magisk Mount and editing some file to re-enable Xposed module won't work?

If MagiskMount still works (I think it does not for 16.3+) you can delete the 'disable'-file from the 'xposed_xx'- folder in the mounted magisk.img.
The Following User Says Thank You to jenslody For This Useful Post: [ View ] Gift jenslody Ad-Free
18th April 2018, 12:54 PM |#6949  
Didgeridoohan's Avatar
Recognized Contributor
Flag Gothenburg
Thanks Meter: 5,019
 
Donate to Me
More
Quote:
Originally Posted by massaquah

Thank you.

And just using Magisk Mount and editing some file to re-enable Xposed module won't work?

Quote:
Originally Posted by jenslody

If MagiskMount still works (I think it does not for 16.3+) you can delete the 'disable'-file from the 'xposed_xx'- folder in the mounted magisk.img.

The Mount Magisk zip currently available in the module collections thread has been updated for Magisk v16.3+.
The Following 2 Users Say Thank You to Didgeridoohan For This Useful Post: [ View ] Gift Didgeridoohan Ad-Free
18th April 2018, 06:29 PM |#6950  
Member
Thanks Meter: 3
 
More
Sadly I have also a bootloop on xperia XZ1 compact, 3.1.5 xposedInstaller , sdk26 and 47.1.A.12.119 firmware.
19th April 2018, 06:50 PM |#6951  
Junior Member
Thanks Meter: 3
 
More
Im using MIUI 9.5 with Nougat
Trying install Xposed SDK24 via latest Magisk v16, but it failed, any suggestions please?
Post Reply Subscribe to Thread

Tags
android pay, ota, systemless, xposed

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes