Remove All Ads from XDA
Honor 7x
Win an Honor 7X!

[EXPERIMENTAL] [UNOFFICIAL] Xposed for arm64 devices | 5.1 and 5.0 versions available

2,385 posts
Thanks Meter: 3,658
 
By Hashbang173, Inactive Recognized Developer / Recognized Contributor on 6th April 2015, 09:19 PM
Thread Closed Email Thread
arm64 is now officially supported: See here



Old OP


Hello Everyone,

I have successfully compiled Xposed for android 5.1.x for arm64 devices.

I have so far tested this on my Nexus 9 running a custom CyanogenMod based Android 5.1 ROM with SELinux disabled (It may work on ROM's with SELinux enabled but testing has to be conducted.).

Install zip is attached to this post. (The SDK 22 one) This will only install Xposed framework for Android 5.1 for arm64 devices. Please see the original Lollipop post to get the other files you need. (Hint: you only need the Xposed APK from that post.)

I compiled this based off of @romracer's source code for Xposed on Android 5.1.x.

So far I have tested the module Lolistat, It seems to be working well.

Please be patient during boot, let your device boot 10 minutes before reporting that it is "bootlooping"

====================

For Android 5.0.x

I have also compiled Xposed for Android 5.0.x for arm64 devices. I have had mixed results from testers so far. The install zip is also attached to this OP (The SDK 21 one). Many HTC M9 users have reported this caused a boot-loop for them.
This will only install Xposed framework for Android 5.0.x for arm64 devices. Please see the original Lollipop post to get the other files you need. (Hint: you only need the Xposed APK from that post.)
Remember to always backup all data before using. Use at your own risk.

Please note: There will most likely be arm64 related bugs with both of these. See this post for more information.

Please be patient during boot, let your device boot for 10 minutes before reporting that it is "bootlooping"

Attached Files
File Type: zip xposed-sdk21-arm64-20150430.zip - [Click for QR Code] (5.28 MB, 60638 views)
File Type: zip xposed-sdk22-arm64-20150514.zip - [Click for QR Code] (5.36 MB, 88764 views)
The Following 127 Users Say Thank You to Hashbang173 For This Useful Post: [ View ] Gift Hashbang173 Ad-Free
 
 
6th April 2015, 09:20 PM |#2  
Hashbang173's Avatar
OP Inactive Recognized Developer / Recognized Contributor
Thanks Meter: 3,658
 
More
just in case...
The Following 8 Users Say Thank You to Hashbang173 For This Useful Post: [ View ] Gift Hashbang173 Ad-Free
6th April 2015, 10:15 PM |#3  
Sim-X's Avatar
Senior Member
Flag Minneapolis, MN
Thanks Meter: 191
 
More
I got a new m9 in the box, thinking about waiting to activate it since xposed wouldn't work on it yet.
6th April 2015, 10:22 PM |#4  
Hashbang173's Avatar
OP Inactive Recognized Developer / Recognized Contributor
Thanks Meter: 3,658
 
More
Quote:
Originally Posted by Sim-X

I got a new m9 in the box, thinking about waiting to activate it since xposed wouldn't work on it yet.

I could also compile Xposed arm64 for android 5.0 if there is enough interest.
The Following 11 Users Say Thank You to Hashbang173 For This Useful Post: [ View ] Gift Hashbang173 Ad-Free
7th April 2015, 12:06 AM |#5  
Hashbang173's Avatar
OP Inactive Recognized Developer / Recognized Contributor
Thanks Meter: 3,658
 
More
Quote:
Originally Posted by Sim-X

I got a new m9 in the box, thinking about waiting to activate it since xposed wouldn't work on it yet.

Somebody would need to be willing to test, but I could try to compile Xposed for it.
The Following 4 Users Say Thank You to Hashbang173 For This Useful Post: [ View ] Gift Hashbang173 Ad-Free
7th April 2015, 08:10 AM |#6  
rovo89's Avatar
Senior Recognized Developer
Thanks Meter: 77,083
 
Donate to Me
More
Well, if you're willing to test and support it, you can post unofficial files for testing...
I have a Nexus 9 with Android 5.0 myself and it's running fairly well. I haven't used any complex modules though.

Be aware that 64-bit ROMs need different handling in a couple of places and break some expectations. For example, initZygote() will be executed twice, as there are two app_processXX processes now. Modules might not expect this. I also didn't succeed to enforce a certain startup order of the processes (app_process64 before app_process32) yet, so results might be a bit random. There are probably more differences like this and it's generally more complex than on 32-bit ROMs. That's why I have only posted files for ARM so far. On the other hand, if you're willing to look into issues that come up (e.g. installation problems, crashes, things that are not working) and do some pre-analysis, that's fine and could bring the project forward. If nothing to major comes up, I can then also include official files with the next version. Additional support would be very welcome anyway.
The Following 27 Users Say Thank You to rovo89 For This Useful Post: [ View ]
7th April 2015, 04:12 PM |#7  
Hashbang173's Avatar
OP Inactive Recognized Developer / Recognized Contributor
Thanks Meter: 3,658
 
More
Framework installation zip attached to OP.
The Following 5 Users Say Thank You to Hashbang173 For This Useful Post: [ View ] Gift Hashbang173 Ad-Free
7th April 2015, 06:12 PM |#8  
PocketFan2015's Avatar
Member
Flag Guangdong
Thanks Meter: 8
 
More
good
7th April 2015, 07:33 PM |#9  
Senior Member
Thanks Meter: 21
 
More
Only for 5.1?
7th April 2015, 07:41 PM |#10  
Hashbang173's Avatar
OP Inactive Recognized Developer / Recognized Contributor
Thanks Meter: 3,658
 
More
Quote:
Originally Posted by auggie246

Only for 5.1?

I made a version for android 5.0 but I would need somebody to test it before I release it.
The Following 2 Users Say Thank You to Hashbang173 For This Useful Post: [ View ] Gift Hashbang173 Ad-Free
7th April 2015, 09:53 PM |#11  
koko115's Avatar
Senior Member
Thanks Meter: 301
 
Donate to Me
More
5.0 for samsung galaxy s6 ?
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes