Remove All Ads from XDA

Xposed on BQ Aquaris X Pro - erros after installation and modules do not work

22 posts
Thanks Meter: 0
 
By Mato_Z, Junior Member on 12th June 2018, 02:45 PM
Post Reply Email Thread
Hello,
I have installed Xposed framework SDK 27 - 90.2.-beta3 via Magisk (16.4) on rooted BQ Aquaris X Pro Android 8.1.0 (Oreo). Install was successful - see screenshot 1. But after reboot and run latest Xposed Installer app (3.1.5) I get information that Xposed Framework is not installed - screenshot 2. In log I see this:
Screenshot1
Screenshot2
Code:
06-12 14:49:29.263 I/Xposed  (  867): -----------------
06-12 14:49:29.263 I/Xposed  (  867): Starting Xposed version 90.2-beta3 (Systemless), compiled for SDK 27
06-12 14:49:29.263 I/Xposed  (  867): Device: Aquaris X Pro (bq), Android version 8.1.0 (SDK 27)
06-12 14:49:29.263 I/Xposed  (  867): ROM: 2.0.0_20180417-1229
06-12 14:49:29.263 I/Xposed  (  867): Build fingerprint: bq/bardock-pro/bardock-pro:8.1.0/OPM1.171019.019/448:user/release-keys
06-12 14:49:29.263 I/Xposed  (  867): Platform: arm64-v8a, 64-bit binary, system server: yes
06-12 14:49:29.263 I/Xposed  (  867): SELinux enabled: yes, enforcing: yes
06-12 14:49:29.299 I/Xposed  (  867): -----------------
06-12 14:49:29.299 I/Xposed  (  867): Added Xposed (/system/framework/XposedBridge.jar) to CLASSPATH
06-12 14:49:32.607 I/Xposed  (  867): Detected ART runtime
06-12 14:49:32.609 I/Xposed  (  867): Found Xposed class 'de/robv/android/xposed/XposedBridge', now initializing
06-12 14:49:33.004 E/Xposed  (  867): Cannot load any modules because /data/user_de/0/de.robv.android.xposed.installer/conf/modules.list was not found
06-12 14:49:39.449 I/Xposed  (  868): -----------------
06-12 14:49:39.449 I/Xposed  (  868): Starting Xposed version 90.2-beta3 (Systemless), compiled for SDK 27
06-12 14:49:39.449 I/Xposed  (  868): Device: Aquaris X Pro (bq), Android version 8.1.0 (SDK 27)
06-12 14:49:39.449 I/Xposed  (  868): ROM: 2.0.0_20180417-1229
06-12 14:49:39.449 I/Xposed  (  868): Build fingerprint: bq/bardock-pro/bardock-pro:8.1.0/OPM1.171019.019/448:user/release-keys
06-12 14:49:39.449 I/Xposed  (  868): Platform: arm64-v8a, 32-bit binary, system server: no
06-12 14:49:39.449 I/Xposed  (  868): SELinux enabled: yes, enforcing: yes
06-12 14:49:39.452 I/Xposed  (  868): -----------------
06-12 14:49:39.452 I/Xposed  (  868): Added Xposed (/system/framework/XposedBridge.jar) to CLASSPATH
06-12 14:49:40.876 I/Xposed  (  868): Detected ART runtime
06-12 14:49:40.878 I/Xposed  (  868): Found Xposed class 'de/robv/android/xposed/XposedBridge', now initializing
06-12 14:49:41.153 E/Xposed  (  868): Cannot load any modules because /data/user_de/0/de.robv.android.xposed.installer/conf/modules.list was not found
06-12 14:50:04.629 W/Xposed  ( 6073): Failed to load Xposed info for /data/dalvik-cache/arm64/system@app@BqTestSuite@BqTestSuite.apk@classes.dex: Unable to open '/data/dalvik-cache/arm64/data@dalvik-cache@arm64@system@app@BqTestSuite@BqTestSuite.apk@classes.dex@xposed' : No such file or directory
Could you help me please?
Attached Thumbnails
Click image for larger version

Name:	screen1.png
Views:	40
Size:	98.1 KB
ID:	4524814   Click image for larger version

Name:	screen2.png
Views:	36
Size:	132.1 KB
ID:	4524815  
 
 
12th June 2018, 03:32 PM |#2  
Didgeridoohan's Avatar
Recognized Contributor
Flag Gothenburg
Thanks Meter: 4,560
 
Donate to Me
More
Did you perhaps skip the first step of the "Install Guide" in the Systemless Xposed support thread?
https://forum.xda-developers.com/xpo...posed-t3388268
The Following User Says Thank You to Didgeridoohan For This Useful Post: [ View ] Gift Didgeridoohan Ad-Free
12th June 2018, 04:23 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Didgeridoohan

Did you perhaps skip the first step of the "Install Guide" in the Systemless Xposed support thread?
https://forum.xda-developers.com/xpo...posed-t3388268

Many thanks! Sure, I installed common version Xposed Installer 3.1.5 not special for Magisk. I am very sorry.
17th June 2018, 09:50 AM |#4  
OP Junior Member
Thanks Meter: 0
 
More
@Didgeridoohan after reinstall according to instructions with XposedInstaller_3.1.5-Magisk.apk I still see errors and modules do not work. Could help me please? My log:

Code:
06-17 10:39:27.439 I/Xposed  (  849): -----------------
06-17 10:39:27.439 I/Xposed  (  849): Starting Xposed version 90.2-beta3 (Systemless), compiled for SDK 27
06-17 10:39:27.439 I/Xposed  (  849): Device: Aquaris X Pro (bq), Android version 8.1.0 (SDK 27)
06-17 10:39:27.439 I/Xposed  (  849): ROM: 2.0.0_20180417-1229
06-17 10:39:27.439 I/Xposed  (  849): Build fingerprint: bq/bardock-pro/bardock-pro:8.1.0/OPM1.171019.019/448:user/release-keys
06-17 10:39:27.439 I/Xposed  (  849): Platform: arm64-v8a, 64-bit binary, system server: yes
06-17 10:39:27.439 I/Xposed  (  849): SELinux enabled: yes, enforcing: yes
06-17 10:39:27.466 I/Xposed  (  849): -----------------
06-17 10:39:27.466 I/Xposed  (  849): Added Xposed (/system/framework/XposedBridge.jar) to CLASSPATH
06-17 10:39:29.188 E/Xposed  (  849): Unable to open /vendor/framework/oat/arm64 to prepare apps for Xposed: Permission denied
06-17 10:39:30.963 I/Xposed  (  849): Detected ART runtime
06-17 10:39:30.965 I/Xposed  (  849): Found Xposed class 'de/robv/android/xposed/XposedBridge', now initializing
06-17 10:39:31.360 I/Xposed  (  849): Loading modules from /data/app/com.oasisfeng.greenify-wJVPxGQEJpZ9wf_JAIsXDg==/base.apk
06-17 10:39:31.526 I/Xposed  (  849):   Loading class com.oasisfeng.greenify.pro.FrameworkPatch
06-17 10:39:31.529 I/Xposed  (  849):   Loading class com.oasisfeng.greenify.pro.SettingsPatch
06-17 10:39:31.529 I/Xposed  (  849): Loading modules from /data/app/dev.ukanth.ufirewall.donate-cH3bIa85cwuqr_CpZUKPlw==/base.apk
06-17 10:39:31.853 I/Xposed  (  849):   Loading class dev.ukanth.ufirewall.xposed.XposedInit
06-17 10:39:37.505 I/Xposed  (  850): -----------------
06-17 10:39:37.505 I/Xposed  (  850): Starting Xposed version 90.2-beta3 (Systemless), compiled for SDK 27
06-17 10:39:37.505 I/Xposed  (  850): Device: Aquaris X Pro (bq), Android version 8.1.0 (SDK 27)
06-17 10:39:37.505 I/Xposed  (  850): ROM: 2.0.0_20180417-1229
06-17 10:39:37.505 I/Xposed  (  850): Build fingerprint: bq/bardock-pro/bardock-pro:8.1.0/OPM1.171019.019/448:user/release-keys
06-17 10:39:37.505 I/Xposed  (  850): Platform: arm64-v8a, 32-bit binary, system server: no
06-17 10:39:37.505 I/Xposed  (  850): SELinux enabled: yes, enforcing: yes
06-17 10:39:37.507 I/Xposed  (  850): -----------------
06-17 10:39:37.507 I/Xposed  (  850): Added Xposed (/system/framework/XposedBridge.jar) to CLASSPATH
06-17 10:39:37.808 E/Xposed  (  850): Unable to open /vendor/framework/oat/arm to prepare apps for Xposed: Permission denied
06-17 10:39:38.920 I/Xposed  (  850): Detected ART runtime
06-17 10:39:38.922 I/Xposed  (  850): Found Xposed class 'de/robv/android/xposed/XposedBridge', now initializing
06-17 10:39:39.198 I/Xposed  (  850): Loading modules from /data/app/com.oasisfeng.greenify-wJVPxGQEJpZ9wf_JAIsXDg==/base.apk
06-17 10:39:39.359 I/Xposed  (  850):   Loading class com.oasisfeng.greenify.pro.FrameworkPatch
06-17 10:39:39.361 I/Xposed  (  850):   Loading class com.oasisfeng.greenify.pro.SettingsPatch
06-17 10:39:39.362 I/Xposed  (  850): Loading modules from /data/app/dev.ukanth.ufirewall.donate-cH3bIa85cwuqr_CpZUKPlw==/base.apk
06-17 10:39:39.659 I/Xposed  (  850):   Loading class dev.ukanth.ufirewall.xposed.XposedInit
06-17 10:40:05.106 W/Xposed  ( 6048): Failed to load Xposed info for /data/dalvik-cache/arm64/system@app@BqTestSuite@BqTestSuite.apk@classes.dex: Unable to open '/data/dalvik-cache/arm64/data@dalvik-cache@arm64@system@app@BqTestSuite@BqTestSuite.apk@classes.dex@xposed' : No such file or directory
17th June 2018, 10:27 AM |#5  
Didgeridoohan's Avatar
Recognized Contributor
Flag Gothenburg
Thanks Meter: 4,560
 
Donate to Me
More
Sorry mate... I have very little working knowledge with Xposed. Haven't used it since Android 6 was released...

All I can say from your log is that you have some kind of permissions issue with /vendor. I'd start working with that.

Good luck...
17th June 2018, 12:06 PM |#6  
OP Junior Member
Thanks Meter: 0
 
More
@Didgeridoohan I understand, thanks. I found similar problems, but not working solution. I hope that someone will help me yet.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes