Remove All Ads from XDA

Xposed N817 ZTE Quest Failure

11 posts
Thanks Meter: 3
 
By fen72521, Junior Member on 4th July 2017, 05:41 AM
Post Reply Email Thread
Xposed N817 ZTE Quest Failure, please help :< sadface
Current Environment:
one N817 ZTE Quest phone;kitkat 4.4.4;sdk19; security patch 2017-01-01;kernel 3.4.0-gb9ccd38-00530-gfb048cc-zte-kernel@Zdroid-SMT. armbli7a cortex-A9 this is an A9 not A7.
initial rooting
superSU & added TWRP
**at this point i tired everything to get xposed to work with releases below, then tried them as priv-app, all failed**

OpenGAPPS stock to replace googleware.
deodex & zip-aligned via kamometoolv7_kitkat
busybox update, 1.26 via f-droid
*i uninstalled and reinstalled various xposed versions, retired installing as system app, all same effect.*
****
official builds i have tired:
i have tried the official releases from the XPOSED repo, 2.5, 2.6, 2.6.1, 2.7.1.
unofficial build i have tired:
xpose 4.4.4+fix solwarz please note this is a FAIL these .so files will brick device. i tired all the solutions in this thread ie both old and newer fixes on the last page & frist. no avail.

currently installed:
XPosed 3.0.1 by dvdandroid -29/04/17
this seems to install the right app_process, in app says bridge 58. this failed then I installed:
xposedbusyboxsuppliement along side from some thread on xda, same effect as without it failure.
XposedStatusText installed one random modual to generate moduals.list that was missing! rebooted...FAILURE.
********
Symptoms & procedure:
install framework thru Flashing or classic system rewrite produces the same effect.
Xposed installer reports everything OKAY, also I can confirm install moved app_process correctly with permissions set.
/Click activate/ then reboot.
Booting gets past manufacture logo and goes to boot animation photo.
*waits 10mins just incase* Stuck at boot animation.
*presses power fast 5x to disable xposed*
phone finished booting into launcher.
check XPOSE, says installed but not activated, logs say nothing out of the ordinary.
retest with PC & adb for logcat.
ADB is available with shell su. logcat loops.
logcat excerpt on page 50 just before looping:
E/dalvikvm(30826): Not whitelisted : /data/data/de.robv.android.xposed.installer/bin/XposedBridge.jar
E/dalvikvm(30826): Unable to construct file descriptor table.
E/dalvikvm(30826): VM aborting
F/libc (30826): Fatal signal 6 (SIGABRT) at 0x0000786a (code=-6), thread 30826 (zygote)
I/DEBUG ( 314): Process: zygote
I/DEBUG ( 314): pid: 30826, tid: 30826, name: zygote >>> zygote <<<
I/DEBUG ( 314): Build fingerprint: 'ZTE/ZTE_WELLINGTON/wellington:4.4.4/KTU84P/20170207.003453.27405:user/release-keys'
I/DEBUG ( 314): Revision: '0'
I/DEBUG ( 314): signal 6 (SIGABRT), code -6 (SI_TKILL), fault addr --------

***
for the socially challenged:
Some information provided maybe irrelevant as such do not go on tangents about irrelevant information! Do not go on tangents about WHY i would want to do anything. the case of the matter is this challenge sits before you, i ask your people's help in getting xposed to work properly on this device.
 
 
4th July 2017, 01:34 PM |#2  
OP Junior Member
Thanks Meter: 3
 
More
XPosed 3.0.1 by dvdandroid -29/04/17 should already have the updated https://github.com/rovo89/Xposed
that rovo89 updated late 2016 to workaround the securty patch from google that forces all zygote loaded stuff (jars) on a whistlist. after reading a 200 post github thread on the subject i am now more confused about what to do besides make a new rom entirely of which is out of the scope of my ability.
Can someone conmpile the latest xposebridge.jar against sdk19 and not sdk23? perhaps then we can use a higher bridge# than 58. or does one need to compile a new app_prosses?? or both?? Rovo has seem to fix the same issue but only updated the 5/6 android installers. Advice would be grand thanks.
12th July 2017, 03:31 PM |#3  
Junior Member
Thanks Meter: 0
 
More
help root
is it even possible to do a root on this device I have been at this for about a month and I cannot find ayone who has successfully rooted this device nor have I even came lose

please help
30th August 2017, 07:17 AM |#4  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by n-817_struggle

is it even possible to do a root on this device I have been at this for about a month and I cannot find ayone who has successfully rooted this device nor have I even came lose

please help

I just successfully rooted this device yesterday. Still need help? If so, I'll tell you and everyone else what I did.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes