FORUMS
Remove All Ads from XDA

[TWRP][E5823] Latest TWRP 3.2.1 for Z5 Compact

723 posts
Thanks Meter: 290
 
By trax7, Senior Member on 13th February 2018, 10:52 AM
Post Reply Email Thread
Updated TWRP for the Z5 Compact

REQUIRES:
- Unlocked bootloader
- Have Fastboot drivers installed on the PC you use for flashing
FEATURES:
- MTP support
- ADB root
- Reboot to Bootloader
- SD Card access

Not working (for now):
- Decryption <- working on it when I have time

Changelog:
23.02.2018
- Backup/Restore fix for USB OTG
- small fstab tuning (thanks @GreyLeshy)
- DL link updated - Now you will have access to all builds inside GDrive folder
22.02.2018 - 2
- Fix SD Card (again) on latest build
22.02.2018
- USB OTG fixed
15.02.2018
- Possibly fixed decryption, need feedback
13.02.2018
- Fixed SD card
7.02.2018
- First build

DOWNLOAD LINK
Google Drive

Instructions:
- Connect phone to PC in Fastboot mode
- Open Command Prompt and type
Code:
fastboot flash recovery recovery-name.img
- Take off the cable and boot into recovery by holding Power + Vol Down until you feel a vibration


Disclaimer: I am merely distributing the ready image. I will do my best to keep this thread up-to-date with the latest TWRP releases and provide fixed images in case there is a bug, I can help you to solve some problems but do not expect any timeframe.
I am not responsible for any bricked phones, missed alarms or thunderstorms. What you do with your phone is your own choice. Happy flashing!

Credits:
@TwrpBuilder for making this, all credits go to them
and all other maintainers and contributors to the code
The Following 17 Users Say Thank You to trax7 For This Useful Post: [ View ] Gift trax7 Ad-Free
 
 
13th February 2018, 08:05 PM |#2  
Member
Thanks Meter: 8
 
More
Quote:
Originally Posted by trax7

Needs testing:
- Decryption

Decryption is not working

Good job anyway, we have an updated TWRP at least!!
14th February 2018, 12:57 AM |#3  
Chronic2k13's Avatar
Senior Member
Flag London
Thanks Meter: 171
 
More
Don't need decryption and everything else works fine!! Strange how md5 checksum is now Digest!! Must be an Oreo thing

Sent from my Sony Xperia Z5 Compact using XDA Labs
14th February 2018, 09:07 AM |#4  
Member
Thanks Meter: 8
 
More
@trax7
I own a Zuk Z2, on it the decryption problem was caused by unaligned/updated vendor blobs. I hope this can give you an hint on how to fix decryption.
The Following User Says Thank You to Doe.it For This Useful Post: [ View ] Gift Doe.it Ad-Free
14th February 2018, 09:21 AM |#5  
trax7's Avatar
OP Senior Member
Thanks Meter: 290
 
More
Quote:
Originally Posted by Doe.it

Decryption is not working

Good job anyway, we have an updated TWRP at least!!

You tried with a password? Try with factory reset (not wipe data) and it should work... Note that you will lose data so be sure to copy it somewhere first.
14th February 2018, 11:06 AM |#6  
Member
Thanks Meter: 8
 
More
Quote:
Originally Posted by trax7

You tried with a password? Try with factory reset (not wipe data) and it should work... Note that you will lose data so be sure to copy it somewhere first.

I am encrypted everyday on my phone (I have set a password), I am using latest official stock firmware, decryption doesn't work returning a "failed decryption" message.
14th February 2018, 12:31 PM |#7  
Senior Member
Thanks Meter: 42
 
More
Thank you!
15th February 2018, 04:55 PM |#8  
rm43115's Avatar
Member
Thanks Meter: 22
 
More
Hello trax7,

first of all ... many, many, many thanks for the provision of a current TWRP !!!!!
I searched for it so long !!!

Quote:

Not working (for now):
- Decryption
- You tell me

For the moment I found three things for need of improvement:

1. When going into Recovery, the purple lamp (at the top of the case) does not light up.

2. Double touch the screen, doesn't wake up / switch on the screen again.

3. When starting a backup, I get five error messages:
unable to locate /persistent partition for backup calculations,
unable to locate /misc partition for backup calculation,
unable to locate /firmware partition for backup calculation,
unable to locate /persist partition for backup calculation,
unable to locate /ta partition for backup calculation,
... but the backup of the five partitions "boot, cache, data, recovery and system" runs through error-free.

However - I'm glad that we have became a current TWRP for our device!
And if one day the decryption works, I will be happy!
15th February 2018, 05:55 PM |#9  
trax7's Avatar
OP Senior Member
Thanks Meter: 290
 
More
Quote:
Originally Posted by rm43115

Hello trax7,

first of all ... many, many, many thanks for the provision of a current TWRP !!!!!
I searched for it so long !!!



For the moment I found three things for need of improvement:

1. When going into Recovery, the purple lamp (at the top of the case) does not light up.

2. Double touch the screen, doesn't wake up / switch on the screen again.

3. When starting a backup, I get five error messages:

unable to locate /persistent partition for backup calculations,
unable to locate /misc partition for backup calculation,
unable to locate /firmware partition for backup calculation,
unable to locate /persist partition for backup calculation,
unable to locate /ta partition for backup calculation,
... but the backup of the five partitions "boot, cache, data, recovery and system" runs through error-free.

However - I'm glad that we have became a current TWRP for our device!
And if one day the decryption works, I will be happy!

That's weird... I haven't experienced any of those bugs Maaybe just the purple lamp but I haven't even paid attention to that lol

Edit: Yes, purple LED does not light up. However the recovery did not complain at all during backups and locking and unlocking the screen is just fine. Are you using E5823 or E5803?
15th February 2018, 11:20 PM |#10  
Member
Thanks Meter: 4
 
More
What about encrypted data partition. Is it possible to fix decrypting?
16th February 2018, 01:53 AM |#11  
trax7's Avatar
OP Senior Member
Thanks Meter: 290
 
More
Quote:
Originally Posted by jw96

What about encrypted data partition. Is it possible to fix decrypting?

At the moment no, but you can try and test whether it picks it up after a factory reset... Backup ur data tho.
Post Reply Subscribe to Thread

Tags
root, twrp, z5 compact

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes