FORUMS
Remove All Ads from XDA

[TUTO] Enable Adoptable Storage on MM

71 posts
Thanks Meter: 14
 
By Elfeno, Member on 11th March 2016, 04:29 PM
Post Reply Email Thread
20th June 2016, 08:35 AM |#21  
Guys is it Z5c only or applicable on Z3 too?
please help.
 
 
22nd June 2016, 12:24 AM |#22  
Senior Member
Thanks Meter: 35
 
More
Tested on Z3 tablet compact and MM 23.4.A.0.575

Works quite well. Camera do not recognize internal memory anymore so format SD Card "Mixed" is mandatory to use Camera (with regular external SD partition)

Move data to adoptable SD move some data that cannot be moved on regular external SD. on a clean phone (cleaned by sd maid) with everything possible moved to regular external SD, I saved 3GB more. nice.

Move app give no gain. only app can be moved on regular external SD can be moved on adoptable SD. nothing more. I kept it on regular external SD to avoid the hassle to move them one by one. move directly app from external SD to adoptable SD crash and reboot tablet. Need to process in 2 steps via normal Internal memory.

Some memory count in setting / storage show crazy negative number. Sony clearly do not update their "written with the foot" code. Just a cosmetic issue.

The only application degraded is Sony Camera. What a shame for Sony.

Envoyé depuis mon SGP621 avec Tapatalk
The Following User Says Thank You to cook For This Useful Post: [ View ] Gift cook Ad-Free
23rd June 2016, 06:53 PM |#23  
Junior Member
Thanks Meter: 1
 
More
Once you shared the SD card would removing it pose any system error or the phone will revert to its stock stated partition?
The Following User Says Thank You to jbrians For This Useful Post: [ View ] Gift jbrians Ad-Free
27th June 2016, 06:17 AM |#24  
zulkhamsyah's Avatar
Junior Member
Thanks Meter: 0
 
More
Hey Guys
please help
i'm running Rooted Stock ROM Marshmallow .570 on my Xperia Z2 D6503
i got this message

Quote:

Error: java.lang.IllegalStateException: command '200 volume partition disk:179,6
4 private' failed with 'null'

when i changed to mixed, it showed same message
can anyone solve this problem ???
2nd July 2016, 10:26 PM |#25  
Junior Member
Thanks Meter: 1
 
More
Z3 Compact now has 2 SD Cards?
So, I applied this to my Z2 Compact using a new Samsung Pro Plus 128gb card and now I have 2 x 64Gb SD Cards listed, not quite what I was expecting...

When I look at apps say Clash Of Clans, it still says it's in internal, but I can change it, that gives me 3 options,
1) Internal
2) SD Card (I've renamed it adaptive)
3) SD Card

If I select 2, it moves the entire app to SD Cards, where as before it'd only move part of the app, so I see that as an improvement. However that's not what I was expecting to see and some apps still can't be moved (No change option)

p.s. when I did sm list-disks I saw disk:179,64 is that the correct format for the id?
The Following User Says Thank You to crox72 For This Useful Post: [ View ] Gift crox72 Ad-Free
3rd July 2016, 07:25 PM |#26  
Junior Member
Thanks Meter: 1
 
More
Also it seems widgets on the "adaptive storage" can't be used...
16th July 2016, 12:20 PM |#27  
Senior Member
Thanks Meter: 192
 
Donate to Me
More
i am trying this right now on my z2... at the moment i have very confusing gb values...
first i tried to use 50% of my 64 gb sd card as internal storage, but i get an error wich says that the number 50 isnt allowed to use.... then i tried using the whole 64gb as adoptable. it seemed to work but i cannot put more than before on my internal storage.... i formatted the sd card before the process... now i can restore 50gb of data lol and no result
27th July 2016, 09:39 AM |#28  
Member
Flag Trawniki
Thanks Meter: 1
 
More
i have got this problem with m4 aqua device problem m4 aqua
27th July 2016, 02:06 PM |#29  
Member
Thanks Meter: 10
 
More
mistake, sorry
11th August 2016, 01:23 PM |#30  
Junior Member
Thanks Meter: 0
 
More
...But I still can't move certain apps to the adopted SD card space. Much like I couldn't move them to the unadopted SD card. So, what's the benefit of this procedure then?! Or am I missing something? Is there a way to force the 'unmovable' apps to move?
15th August 2016, 02:08 PM |#31  
Senior Member
Thanks Meter: 575
 
Donate to Me
More
Works with Xperia XA, just a display bug on total partition size. Thanks
Post Reply Subscribe to Thread

Tags
functionality, marshmallow, sdcard, storage

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes