FORUMS
Remove All Ads from XDA

An Actual Solution to the Rooting Crisis of the Zenfone 3 Max !(ZC520TL)

7 posts
Thanks Meter: 12
 
By dr_awesome867, Junior Member on 14th September 2017, 12:13 AM
Post Reply Email Thread
I have something here today that will blow the socks off of the people here that own a Zenfone 3 Max and have wanted to root their device.
First of all, this is my first post here. Second of all, I can not be held responsible for anything that happens to your device during installation or anything that happens as a result (global thermonuclear war, getting fired because your alarm doesn't work, etc.) Lastly, I would like to credit the developer of Magisk, topjohnwu and the guy on Zentalk that found this, ukolino.

ASUS attempted to push a bootloader unlock for this phone through a bootloader unlocker on their website, but they failed miserably as the tool would simply reboot the phone and do nothing else. When checking the lock status through ADB, it was always locked.

I will go ahead and explain the procedures I went to in order to get to this:

1. I don't know if this influences the results or not, but I did run the bootloader unlock tool from ASUS previously. I didn't have it installed at the time of installing Magisk. The download for the .apk can be found at https://www.asus.com/us/Phone/ZenFon...Desk_Download/

2. While you are on ASUS' website, you are going to need the firmware for the region model of your phone. Mine is a US, so I used the US firmware. If you don't know what region model your device is, you can find it by going to settings--> system updates --> build number. Mine says NRD90M.US_Phone-14.... While this is downloading, proceed to the next steps.

3. You are obviously going to need ADB for this. If you have the Android SDK, that works. I am using Minimal ADB and Fastboot and seriously suggest it over the giant SDK if you just need ADB and Fastboot.

4. Next, you are going to need Magisk Manager. It can be found at http://tiny.cc/latestmanager . If you want to read up more about Magisk, you can go to https://forum.xda-developers.com/app...mless-t3473445

5. Install Magisk Manager like any old .apk.
Now you must wait for your firmware to finish downloading from ASUS.

6. Now that your download is finished, you will need to open the .zip. Inside the zip is a bunch of files, one being boot.img. You will need to extract it. All that wait for a 9mb file....

7. You will need to move the boot.img to your phone through traditional means.

8. You will now use the Magisk Manager you installed earlier to make a modified boot image out of the stock one you just extracted. In Magisk, you need to press install, install again, patch boot image file, and navigate to the area where you stored the boot.img.
9. After selecting your boot.img, a terminal-esque window will pop up and if all goes well, it will drop a modified boot.img named patched_boot.img in (Main Storage)--> MagiskManager. Move this to your PC in an easy to locate space. I put mine at C:/android.

10. Now comes the scary stuff; ADB. I am not too experienced with ADB, so any extraneous problems encountered here may require a Google search. Make sure you have USB debugging enabled in Developer Options. Your phone will need to be connected to the PC for the rest of the process.

11. In an ADB prompt, you will need to put your phone into bootloader mode by keying in:
Code:
adb reboot-bootloader
12. Your phone will soon reboot and will be in bootloader mode. This is where things get modified and you may want to pray to whatever higher being you believe in that this works and doesn't brick your device. You can ensure that your phone is in the right mode by typing
Code:
fastboot devices
. After this, you can type
Code:
fastboot flash boot c:/android/patched_boot.img
. Replace c:/android with the path of the place that you put the patched_boot.img from Magisk.

13. It should take no time at all (mine took a total of 0.993 seconds), and after it is finished, you can go ahead and reboot with the buttons or you can type
Code:
fastboot reboot
. Your phone should reboot regularly and won't look any different.

14. Open up Magisk Manager again. It should say that you're rooted. If it does, congratulations, you have systemless root! If it doesn't, try again. If it doesn't fix it then, reply and I'll look into it.

15. (optional) In the hamburger menu, there is a place called downloads. It contains such beauties as Xposed Framework and ViPER4Android FX. Since there's no custom recovery involved, you can't flash anything, but you can still use root-enabled apps with ease!

I believe I covered all of the bases here, but if I didn't, please feel free to reply with any questions and I'll do my best to answer them.

Cheers!
The Following 11 Users Say Thank You to dr_awesome867 For This Useful Post: [ View ] Gift dr_awesome867 Ad-Free
 
 
14th September 2017, 05:54 PM |#2  
Senior Member
Flag Kalimpong
Thanks Meter: 37
 
More
U can use flasfire to flash any zip you want.

So you were able to root using Magisk without unlocking bootloader, thats awesome. I unlocked my friends phone for the same.
14th September 2017, 11:31 PM |#3  
Senior Member
Thanks Meter: 57
 
More
tried on zc553kl zenfone max, it does not work, it does not boot.
15th September 2017, 03:36 AM |#4  
Junior Member
Thanks Meter: 0
 
More
Sorry for the stupid question.
sorry the question idiot else has not even a file or something like boot.img in the zip file what would the file be? would have a magisk installation tutorial via adb / fastboot this is my first zenfone aff longing for samsung already
20th September 2017, 02:32 PM |#5  
Senior Member
Thanks Meter: 80
 
More
I have followed the instruction and everything seems to work okay except after the fastboot reboot Magisk manager is stuck on the loading screen with the mask and after about a minute it crashes. and apps that require root dont work
3rd October 2017, 08:40 PM |#6  
Junior Member
Thanks Meter: 0
 
More
You're a ****ing genious men! Thank you! Too much! <3
4th October 2017, 05:51 AM |#7  
Junior Member
Thanks Meter: 0
 
More
After i rooted the device (thanks so much), i installed viper4android. Then, i tried to install xposed framework (all from the hamburguer menu). The xposed never showed or installed (i cant find id) and messenger and facebook apps keep crashing and crashing. I tried to uninstall them, without any app, and nothing. Also, the overall performances is a lit bit slow than before. Well quite slower. Any ideas? Thanks in advance.
6th October 2017, 10:35 PM |#8  
Member
Flag Campinas
Thanks Meter: 21
 
More
Thank you. You are a genius!
I realized that the Asus tool did not unlock the bootloader, so I could not perform the ROOT by SP Flash Tools or anything like that.
The command in ADB "fastboot flash recovery recovery ...... twrp.img did not work either.
But once thanks, I'm going to record a video in PT BR for the Brazilians and thank you.

PT BR

Obrigado. Você é um gênio!
Eu percebi que a ferramenta da Asus não desbloqueava o bootloader, então eu não conseguia realizar o ROOT pelo SP Flash Tools ou alguma coisa desse tipo.
O comando no ADB "fastboot flash recovery recovery......twrp.img não funciovava também.
Mas uma vez obrigado, vou gravar um vídeo em PT BR para os brasileiros e agradeço a você.
8th October 2017, 11:04 PM |#9  
Member
Flag Campinas
Thanks Meter: 21
 
More
Thanks again. I make a details guide and a video. Please, see https://forum.xda-developers.com/zen...520tl-t3685835
The Following User Says Thank You to PedroArmindo For This Useful Post: [ View ] Gift PedroArmindo Ad-Free
10th October 2017, 10:00 PM |#10  
Junior Member
Thanks Meter: 1
 
More
recovery play to function
Someone knows how to recover the mirror smart tv play to function of this cell phone ZC520TL???.
The Following User Says Thank You to alexandroid81 For This Useful Post: [ View ] Gift alexandroid81 Ad-Free
11th October 2017, 08:36 AM |#11  
MezzaLuna's Avatar
Member
Thanks Meter: 15
 
More
Quote:
Originally Posted by alexandroid81

Someone knows how to recover the mirror smart tv play to function of this cell phone ZC520TL???.

I think you own the ZC520TL with the mediatek MT6737 (I own the same).
This is a well known issue with this model, no play to(screen mirroring) default feature and no full HD videos.
The lucky one who owns the MT6737T they have play to and full HD videos, since the hardware is the same Asus sold to some unlucky users this poorest version.
At moment there is nothing you can do, may be (if you are rooted) there is a xposed moduel to do it...
By the way if the device is on the same wLan of a smart tv you can pair them.

Asus officially say that this device it is not designed for screen mirroring(it's a lie they just haven't optimized the software for the MT6737 processor), but if you want try to protest...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes