FORUMS

[VoLTE] How to enable VoLTE - Without Root [Z012D/Z017D]

28 posts
Thanks Meter: 11
 
By FernandoSilva, Junior Member on 28th March 2018, 03:57 PM
Post Reply Email Thread
It is not necessary to do Root, nor will it lose the guarantee (if it is still on time).

This method requires:

1 - Enable "Developer Options" and USB debugging enabled.
2 - Computer running Windows, MAC OS or Linux
3 - USB cable

Note: Check the availability of your mobile service provider, in some cases it may be that VoLTE is not included in your locality.

Enabling Developer Options:

Settings -> System -> About Phone -> Software Info -> Build number. Tap on the section 7 times

Settings -> System -> Developer options -> USB debugging -> ON

Connect the device to the computer, open the command prompt or Terminal (Linux or MAC OS) and perform the commands below:

First verify communication with the cell phone via USB cable:

Code:
adb devices
Followed by the ENTER key to confirm.

On your device screen will a "Allow USB debug?" Prompt appear, you must confirm the OK button.

Enable VoLTE in Build.prop

Code:
adb shell setprop persist.dbg.ims_volte_enable 1; setprop persist.dbg.volte_avail_ovr 1; setprop persist.dbg.vt_avail_ovr 1; setprop persist.dbg.wfc_avail_ovr 1
Followed by the ENTER key to confirm.

How to check:

Settings -> Connections -> Call -> Wi-Fi calling -> On
Settings -> Connections -> Mobile network -> Enhanced 4G LTE Mode -> On

Images: https://imgur.com/a/hmj4k

Disable VoLTE in build.prop

To disable, just follow the same path to enable, but this time you should change the command by this below:

Code:
adb shell setprop persist.dbg.ims_volte_enable 0; setprop persist.dbg.volte_avail_ovr 0; setprop persist.dbg.vt_avail_ovr 0; setprop persist.dbg.wfc_avail_ovr 0
Important Notes: I've been watching and found that this feature is off on the device for my country. Unfortunately I do not know exactly what is required to activate it, I was able to only enable the functions hidden in the settings menu, but I could not test in practice because my telephone company does not provide VoLTE.

I believe it is necessary to add and modify files in the system. Unfortunately, I can not work on the rest of this project.

If anyone can contribute can share knowledge, maybe we can improve and make this feature functional.
The Following 9 Users Say Thank You to FernandoSilva For This Useful Post: [ View ] Gift FernandoSilva Ad-Free
26th September 2018, 06:06 AM |#2  
Senior Member
Thanks Meter: 13
 
More
The command works but doesn't appear a VoLTE icon. I'll wait by tomorrow to do calls and test it. Thanks!
1st October 2018, 11:41 PM |#3  
Junior Member
Thanks Meter: 0
 
More
It is not working on my LG G5 H860N
28th April 2019, 02:01 PM |#4  
Junior Member
Thanks Meter: 0
 
More
Not working for me.

Anyone faced this issue?

setprop: failed to set property 'persist.dbg.ims_volte_enable' to '1'
setprop: failed to set property 'persist.dbg.volte_avail_ovr' to '1'
setprop: failed to set property 'persist.dbg.vt_avail_ovr' to '1'
setprop: failed to set property 'persist.dbg.wfc_avail_ovr' to '1'
29th April 2019, 07:44 AM |#5  
Senior Member
Thanks Meter: 39
 
More
For me it's working.
7th July 2019, 08:17 PM |#6  
Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by JoaoCecchetto

Not working for me.

Anyone faced this issue?

setprop: failed to set property 'persist.dbg.ims_volte_enable' to '1'
setprop: failed to set property 'persist.dbg.volte_avail_ovr' to '1'
setprop: failed to set property 'persist.dbg.vt_avail_ovr' to '1'
setprop: failed to set property 'persist.dbg.wfc_avail_ovr' to '1'

I am having this same issue on my Asus Zenfone 6. If anyone knows how to get it to work then that would be great
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes