FORUMS

Issue with flashing magisk on BlurOS (Asus t00j/t00f)

2 posts
Thanks Meter: 1
 
By RedDevilHam, Junior Member on 23rd May 2020, 09:48 AM
Post Reply Email Thread
Hi Folks,

I am new to rooting and struggling with a problem. I have an old zenfone 5(ASUS_T00J) model. I am using custom rom BlurOS found in the below thread:
https://forum.xda-developers.com/zen...one-5-t3619058

I am trying to flash Magisk from TWRP recovery but it's failing with below error:
E: Unknown File System: 'osip'
E: Unknown File System: 'osip'
E: Unknown File System: 'osip'
E: Invalid Block device on '/dev/block/zram0
none
swap
defaults
zramsize=67108864
', 'swap', 36

Updating partition details..
...done
Full SELinux support is present.
MTP Enabled
Installing '/sdcard/Download/Magisk-v20.4(20400).zip'..
Checking for MD5 file...
Skipping MD5 check: no MD5 file found
**********************
Magisk 20.4 Installer
**********************
- Mounting /system
- Target Image: /dev/block/by-name/boot
- Device platform: x86
- Constructing environment
- Adding addon.d survival script
E: Error executing updater binary in zip '/sdcard/download/Magisk-v20.4(20400).zip'[/QUOTE]
Error flashing zip '/sdcard/download/Magisk-v20.4(20400).zip'
Updating partition details...
...done


Updatrer Scripts are in below Google Drive Location:
https://drive.google.com/file/d/1Sdt...ew?usp=sharing (Updater Script)
https://drive.google.com/file/d/1X2l...ew?usp=sharing (Updater Binary)

Steps followed by me:
1. Installed latest Magisk manager from GitHub
2. Downloaded the latest zip file prompted by Manager
3. Reboot in TWRP recovery
4. Flashed the newly downloaded zip file

Appologies in advance if this is not the right forum or I have violated any guidelines. Let me know if you need any more details from my side. Thanks in advance.
29th May 2020, 07:19 PM |#2  
OP Junior Member
Thanks Meter: 1
 
More
Update
The issue still remains. Tried to find solutions online. Below methods were suggested. Since, I am new to this, might have tried something silly in the process.

Method 1:
Flash the Rom boot image via TWRP
Result: Did not prompt to provide any partition but Failed with error 'No Partition selected for flashing'. Updated the TWRP to 3.2.3 and tried the same thing again. This time prompted for a partition but no option was available that I could provide there and failed with the same error.

Method 2:
Patching the Boot image of my ROM through magisk patch
Result: Extracted the boot image for BlurOS Custom rom and tried to patch it through magisk Manager. Installation failed with 'Unable to repack boot image'.

Since I updated the TWRP, tried to flash the magisk zip file hoping for some other error (at least). It failed with below error message:
Installing zip file '/sdcard/Download/Magisk-v20.4.zip'
Checking for digest file...
Skipping Digest check: No digest file found
*************************
Magisk 20.4 Installer
*************************
- Mounting /system
! Unable to detect target image
- Unmounting partitions
Updater process ends with error: 1
Error Installing zip file
Updating partition details...
... done


Kindly let me know if you guys have any pointers. Any leads will be appreciated.
The Following User Says Thank You to RedDevilHam For This Useful Post: [ View ] Gift RedDevilHam Ad-Free
1st July 2020, 03:29 PM |#3  
Junior Member
Thanks Meter: 0
 
More
Magisk is unable to patch x86 boot.img's, so you have to use "android image kitchen"
Magisk patches Ramdisk file so you have to do:

move x86 ramdisk to ARM boot.img
Patch it via magisk
move patched ramdisk back to x86 boot.img

You can try boot.img's that I made for RR and Lineage in my thread. They are pre-patched with magisk 20.4


Anyways, is BlurOS better than lineage or RR ?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes