FORUMS
Remove All Ads from XDA

[EOL] [ROM] WIP CM12.1 [LMY49J] for ZTE Blade S6 (P839F30) - development thread

203 posts
Thanks Meter: 209
 
By lightwars, Senior Member on 6th November 2015, 12:18 PM
Post Reply Email Thread
This development has come to a stop!
But further development is taken here.

Many thanks.



Hello everyone,

I start this thread to get some more development going on for the ZTE Blade S6.
It should encouraged others to join in or describing their own rom development for this device.

To start with I will show you my first alpha build, which means that most basic function should work now, of Cyanogenmod 12.1 for the Blade S6 (P839F30). I have the AS-Version of the device so be careful, if you have a EU Blade S6 or some other similar device. But at always be careful with your device, because I'm not responsible what you do with it, make a backup with TWRP before flashing the rom.

Things I tried:
called my phone
mobile Internet
wifi shows access Points
sound
button lights
camera working
breathing notification

Not Working:
Flash don't work when taking pictures.
UMS is not working correct

Preparation:
download unofficial CM12.1 and put it on your external sd Card
make a twrp backup
factory reset your device
optional - install this mod
install CM12.1
optional - install other region kernel - AU, EU
optional - install gapps


Credits:
Whole team of CyanogenMod https://github.com/CyanogenMod/android
lonespeaker for helping getting things started
KonstaT for TWRP
repos from piccolo-dev team, at which my work is based on.
Kernel Sources my own kernel repo
Kernel Sources ZTE

Please note this is the first time I do this, I'm still learning while doing and also some things I don't know.
Download Google drive
Updated Version 16.11.2016
using data/media as internal storage

Download links for the different kernels:
EU Version
AU Version

Previous Version 20.06.2016
10.02.2016
Attached Thumbnails
Click image for larger version

Name:	screen1.jpg
Views:	8130
Size:	44.1 KB
ID:	3533029   Click image for larger version

Name:	screen3.png
Views:	8046
Size:	202.5 KB
ID:	3533031   Click image for larger version

Name:	screen4.png
Views:	8674
Size:	92.0 KB
ID:	3548905   Click image for larger version

Name:	screen5.png
Views:	8448
Size:	76.4 KB
ID:	3548906   Click image for larger version

Name:	after.png
Views:	8138
Size:	50.9 KB
ID:	3571436  
The Following 25 Users Say Thank You to lightwars For This Useful Post: [ View ] Gift lightwars Ad-Free
 
 
7th November 2015, 07:10 AM |#2  
Senior Member
Flag Munich
Thanks Meter: 25
 
More
Concerning the wifi issue you could try the wifi zip file from fortek..see https://mega.nz/#F!c9AyURra!H4Oew0HB6JmqfPpmQ4SJqA
8th November 2015, 10:52 PM |#3  
Member
Thanks Meter: 6
 
More
Something new here ??
9th November 2015, 12:21 PM |#4  
OP Senior Member
Flag Wuppertal
Thanks Meter: 209
 
Donate to Me
More
Quote:
Originally Posted by slawoko

Concerning the wifi issue you could try the wifi zip file from fortek..see https://mega.nz/#F!c9AyURra!H4Oew0HB6JmqfPpmQ4SJqA

Hey, yes this should work. I think in the official kernel source from zte the config for wifi is missing.
Maybe they have done it any other way. Will cherry pick some commits and hope wifi will be alright then.
10th November 2015, 07:21 PM |#5  
Senior Member
Flag North East England
Thanks Meter: 323
 
More
Quote:
Originally Posted by lightwars

Hey, yes this should work. I think in the official kernel source from zte the config for wifi is missing.
Maybe they have done it any other way. Will cherry pick some commits and hope wifi will be alright then.

If the blade is the same as the SU6, copy the pronto_wlan.ko module from stock to vendor/vodafone/p839v55/proprietary/lib/modules (or whatever you've named the directory structure) and in the BoardConfig.mk in the device tree put

BOARD_HAS_QCOM_WLAN := true
BOARD_WLAN_DEVICE := qcwcn
BOARD_HOSTAPD_DRIVER := NL80211
BOARD_HOSTAPD_PRIVATE_LIB := lib_driver_cmd_qcwcn
BOARD_WPA_SUPPLICANT_DRIVER := NL80211
BOARD_WPA_SUPPLICANT_PRIVATE_LIB := lib_driver_cmd_qcwcn
WIFI_DRIVER_MODULE_PATH := "/system/lib/modules/pronto/pronto_wlan.ko"
WIFI_DRIVER_MODULE_NAME := "wlan"
WPA_SUPPLICANT_VERSION := VER_0_8_X

That worked for the SU6.

(you might need something in the device.mk file I can't remember, give me a shout if this doesn't work).
13th November 2015, 05:27 PM |#6  
fortek_4pda's Avatar
Junior Member
Flag Saint-Petersburg
Thanks Meter: 48
 
Donate to Me
More
in my cyanogenmode 12.1 for zte blade worked all. release version will be the end of the month
The Following User Says Thank You to fortek_4pda For This Useful Post: [ View ] Gift fortek_4pda Ad-Free
20th November 2015, 09:03 AM |#7  
OP Senior Member
Flag Wuppertal
Thanks Meter: 209
 
Donate to Me
More
New Version with synced cm sources uploaded, wifi should know work.

Next step to get internal sdcard function properly and Sound working is very important.

Changes could effect that EU variant could work too, but I don't own one to test it. Please be careful.
30th November 2015, 06:02 AM |#8  
OP Senior Member
Flag Wuppertal
Thanks Meter: 209
 
Donate to Me
More
So I think the button backlights will work in next version and I trying to get the sdcard working.
Why the sound is not working properly, I don't know at this time...
30th November 2015, 06:42 AM |#9  
Junior Member
Thanks Meter: 8
 
More
Check fortek's version may be, sound works fine there
1st December 2015, 08:28 AM |#10  
OP Senior Member
Flag Wuppertal
Thanks Meter: 209
 
Donate to Me
More
So I got a newer build working, which has working audio. What is wired that sim card isn't detected, which seems as a problem.
Internal sdcard is accessible through file manager. And unfortunately button illumination do not work, which should be okay, I had done some tests before... So another build is needed which hopefully combine all things that work.
The Following User Says Thank You to lightwars For This Useful Post: [ View ] Gift lightwars Ad-Free
1st December 2015, 03:19 PM |#11  
Member
Thanks Meter: 15
 
More
So.. Sim Card isnt working in this build?
And does it work properly on EU / DEU (german) Version?
Post Reply Subscribe to Thread

Tags
blade s6, cm12.1, p839f30, zte-blade-s6

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes